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CHAPTERT

Upgrade Preparations

Chapter 1 guides you through the steps necessary to prepare the upgrade.

The following topics are included in this Chapter:

1.1 Determining the Current System Software ... 6
1.2 Determining the Correct Upgrade Procedure ................................ 8
1.3 Determining Remaining Disk Life ... 8
1.4 Freeing Up Disk SRACE ..o 9
1.5 Downloading the Upgrade Software Bundle .................................. 12
1.6 Hardware-Specific STePS ... 12
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1.1 Determining the Current System Software

First, determine which system software version is currently installed on your
SecureSync:

1.1.1 Using Version 5.1.2 and Above

1. Inthe SecureSync Web User Interface (Web Ul), navigate to Tools > Sys-
tem: Upgrade/Backup.

™
WMAGEMENT TOOLS

Alarms
Authorization
Events
Journal

NTP
Oscillator

System Configuration

System Spectracom [ product | 18 Vers 5.2.0

Model 1209-012

Serial # 01396

Power Supply

Oscillator

2. Take note of the system software version number.

1.1.2 Using Version 5.0.2 and Below ("Old Style"” Web Ul)

1. Inthe Web Ul, navigate to Tools > Versions.

[status [setup o[ Network [ Tools

UPGRADE/BACKUP

6 SecureSync Software Upgrade Instructions Rev. [33]
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1.1 Determining the Current System Software

MODEL AND SERIAL NUMBER

1200123

000000

SYSTEM VERSION

Spectracom [produd w

SW V3.0.2 FPGA 00 V01

Empty

Empty

Empty

Empty

Empty

Empty

FPGA AND FIRMWARE VERSION

3.02

3.02

210

2.10

2. Take note of the Archive Version number.

SecureSync Software Upgrade Instructions Rev. [33]
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1.2 Determining the Correct Upgrade Procedure

There are two possible upgrade scenarios:

[. If your currently installed software is Version 5.8.2 or higher, proceed to
"Upgrade Procedure"” on page 17.

[I. If your currently installed software is 5.8.1 or lower: It is recommended that
you contact Safran Navigation & Timing Technical Support for assistance
upgrading; since your software has been out of date for so long, there is a
risk of upgrade failures or system problems. See "Technical Support” on
page Xii.

With both scenarios, before beginning with the actual software installation, you
must first complete all necessary steps in CHAPTER 1.

If you download more than one file, the files will be bundled into one compressed
file that you need to extract, once it has been downloaded. Thereafter, only
upload the file updatexxx.tar.gz (where xxx = software version) to the unit to
be upgraded.

1.3 Determining Remaining Disk Life

SecureSync uses a Compact Flash (CF) memory card for storing logs, con-
figurations and software. Certain rare conditions can reduce the disk life to the
point where the unit is unable to upgrade. This condition is unrelated to the
memory capacity; instead, the disk health is an expression of the length of time
the CF card will continue to operate.

1.3.1 Disk Health Check

The Disk Health Check is available after SW V 5.8.5 or through an applied hot-
patch.

In order to view the length of time remaining in the operation of your disk:
» | ogontothe Web Ul
» Navigate to TOOLS Upgrade/Backup

» The Disk Health panel is on the lower left of the screen

Disk Health Results

» Health OK - Healthy disks are capable of conducting a software upgrade
and have more than three months of estimated operating "life” left. You are

SecureSync Software Upgrade Instructions Rev. [33]
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1.4

1.4.1

SecureSync Software Upgrade Instructions Rev. [33]

1.4 Freeing up Disk Space

okay to upgrade if your Disk Health is listed as No Disk Maintenance
Required.

» Less than 1year - If your Disk Health is listed as less than one year but more

than three months, you may conduct a software upgrade but do still need
to contact Technical Support for more information.

» Less than 3 months - If your Disk Health is listed as less than three months,

do not attempt a software upgrade. Contact Technical Support.

Freeing up Disk Space

SecureSync uses a Compact Flash (CF) memory card for storing logs, con-
figurations and software. Over time, the Compact Flash card can contain many
log entries and any previous software update files retained from earlier software
updates.

If the CF card usage is higher than normal when a software update is performed,
this can potentially result in the loss of some or all of the unit’s configurations
upon completion of the software update process or may prevent the update
from being able to begin. It may be necessary for the unit’s logs and previous
update files to be deleted before performing software updates.

The logs can be backed-up to a single bundled fine and then extracted before
deleting them, if required by your organization. The processes to easily delete
logs and previous Update files before updating the software is described within.

Note: An available CLI command (df -h) can be used to read what
percentage of the CF card is currently in use, to determine if the logs
and update files should be deleted. In general, if the CF card usage is
more than around 70 % or so, the logs and any previous software
update files should be deleted to ensure there is plenty of space in
the CF card to persist the config files and to be able to perform the
upgrade.

Determining Current Disk Usage

There are two ways to determine the usage, via the Web Ul, or using the Com-
mand Line Interface (CLI):

Determining Disk Usage via the Web Ul
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1. Inthe Web Ul, navigate to TOOLS > SYSTEM: Upgrade/Backup.

2. In the Disk Status panel in the bottom-left corner of the screen, the Percent
value indicates what percentage of disk space is currently used.

Determining Disk Usage via the CLI

Login to the CLI (telnet or ssh) and at the command prompt, type: df -h <enter>
(as shown below). The “Use%” column in the “/dev/hdal” row will indicate the CF
card usage (65 % in this example, which indicates the logs and any previous
Update files do not need to be deleted before performing the update process.)

1.4.2 Archiving and Deleting Log Files

If the disk usage is higher than 70% (approximately), Spectracom recommends
that you delete the logs and update files that may have been previously applied
before performing the system software upgrade.

Archiving Logs

As an option, the logs can be archived (backed up) before deletion, by bundling
them into a single file, and then transferring them to your PC, all from within the
SecureSync Web Ul.

To archive logs:
1. Inthe Web Ul, navigate to MANAGEMENT > OTHER: Log Configuration.

2. Click on Save and Download All Logs. This will generate a single bundled
file (*.1log) of the logs. Select where to save this file on your PC.

Deleting Logs and Statistics

To delete log files and statistics files, in order to cleanup disk space:
1. In the Web Ul, navigate to TOOLS > SYSTEM: Upgrade/Backup.

2. In the bottom-left corner of the screen, take note of the Percent value, indic-
ating how much disk space is currently used.

3. Then click on Clear All Logs, and then Clear All Stats below.

10 SecureSync Software Upgrade Instructions Rev. [33]
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4. After completion of the process, the Percent value should show a smaller
number, indicating how much disk space was cleared.

1.4.3 Deleting Old Update Files

Update files used in previously executed software upgrades are stored in the
home/spectracom directory. You can delete them individually via the Web Ul
(they are no longer used by the System, after the update has been applied).

To delete each update file:

1. Inthe Web Ul, navigate to Tools > Upgrade/Backup (see illustration
below):

2. Click on the button Update System Software in the top-left corner. The
Upgrade System Software window will open (see illustration below):

Upgrade System Software

Upload New File

3. The drop-down list will display each update file currently stored in the
SecureSync Compact Flash Card. Select the file to be deleted, and check
the Delete Upgrade File checkbox. Then click Submit.

4. Repeat this process to delete any other listed update file.

1.4.4 Disk Cleanup Patch

Under some circumstances, clearing logs and stats conventionally via the Web U
(as described above) will require a second step in order to achieve an optimum
restoration of disk space.

SecureSync Software Upgrade Instructions Rev. [33] n
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1.5

1.6

1.6.1

To this end, Spectracom provides a Disk Cleanup Patch that can be downloaded
with instructions from https://files.spectracom.com/public-
downloads/updatecleaner-securesyncnetclock-9400, and run from within the

Web Ul. This Patch will clean items that are not user accessible otherwise.

Downloading the Upgrade Software Bundle

The new version system software upgrade (as well as previous versions, if
needed) can be downloaded from the Spectracom Corporate website, see:

Spectracom Support page for SecureSync

?» Download the file(s) onto your PC, and note the location. If you download
more than one file, the files will be bundled in a compressed file that needs
to be extracted after download. Then, only upload the file upda-
texxx.tar.gz totheunittobe upgraded (where xxx = software version).

Hardware-Specific Steps

With certain hardware configurations and option cards (see below), the cor-
responding procedures described below must be carried out when upgrading
from Versions 5.0.2 or higher to Version 6.0.0.

These instructions apply only, if one or several of these are installed:
» Trimble RES-SMT-GG Receiver
» Simulcast Option Card (Model 1204-14)
» 10/100 PTP Option Card (Model 1204-12)
» Gigabit Ethernet Option Card (Model 1204-06)

Please note that these option-card related procedures must be carried out only
once, i.e. if you have previously upgraded your system from Version 5.0.2 to e.g,,
5.1.5, you can skip this section.

Trimble RES-SMT-GG Receiver and u-blox M8T Receiver

Units shipped between 2Q 2014 and 3Q 2016 typically have a RES-SMT-GG GNSS
receiver installed, while units built thereafter are equipped with a u-blox M8T
receiver.

With either receiver, it may be necessary to execute the installation procedure
twice in order to install not only the SecureSync system software update, but
also a GNSS receiver firmware update:

SecureSync Software Upgrade Instructions Rev. [33]
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&

a. If your unit has a RES-SMT-GG receiver, AND you are upgrading from a ver-
sion less than 5.1.5 to a higher version (does not apply to SAASM GPS
SecureSyncs).

? When upgrading from version 5.0.2 to 5.1.5 or higher, see "Required
Repeat of Upgrade Process” on page 23.

?» \When upgrading from version 5.1.2 to 5.1.5 or higher, see "Potential
Need to Repeat Upgrade Process” on page 30.

b. If your unit includes a u-blox M8T receiver, AND you are upgrading from
version 5.5.0 or lower to 5.6.0 or higher.

? See "Potential Need to Repeat Upgrade Process” on page 30.

Note: In cases other than the ones described above, the firmware
update will be skipped automatically.

1.6.1.1 Determining the GNSS Receiver

Next, you need to determine which type of GNSS receiver is installed in your
SecureSync.

Note: If the default Web Ul of your unit is blue/white (rather than
dark grey), your unit has a Res-T receiver.

1. If your Web Ul is dark grey (see illustration below), navigate to Interfaces ->
GNSS 0. The first line item under the default Main tab will report the GNSS
receiver Model that is installed in your SecureSync. The example shown in
the illustration below shows a "RES-SMT GG" receiver.

@ Main

2. Take note of the receiver type installed in your unit.

1.6.2 Simulcast Option Card (Model 1204-14)

Simulcast/CTCSS Option Cards (Model 1204-14) have one RJ-45 jack and should
be identified with a small “14” label screened onto a corner of the metal plate of

SecureSync Software Upgrade Instructions Rev. [33] 13
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the Option Card itself).

Due to a software change in the version 5.1.2 update to address an issue with the
9600 baud output, the settings of this particular Option Card need to be “resub-
mitted” just one time, after applying the next subsequent update version beyond
version 5.0.2. The issue with the 9600 baud output, if configured, will still be ini-
tially present after applying the version 5.1.2 or higher software update, until the
configurations of this Option Card are “resubmitted” one-time.

To “resubmit” the settings, navigate to the “Interfaces” page of the browser and
select the Simulcast Option Card. With the settings displayed, simply press the
“Submit” button to refresh the settings. This will resolve the issue with the 9600
baud output. Note this additional step does not need to be performed again,
after any subsequent software updates are applied.

1.6.3 10/100 PTP Option Card (Model 1204-12)

[B Note: Not applicable to the Gb PTP Option Card Model 1204-32.

10/100 PTP Option Cards (Model 1204-12) have one Ethernet jack and can be
identified with a small “12” label screened onto a corner of the metal plate of the
Option Card itself.

When there are software updates that need to be automatically applied to the
10/100 PTP Option Cards during the upgrade process, the upgrade process will
take an additional 5 to 7 minutes longer, for each 10/100 PTP Option Card that is
installed.

1.6.4 Gigabit Ethernet Option Card (Model 1204-06)

Note: This section is not applicable when previously upgrading from
versions 5.1.2 and above and the Ethernet ports have already been
enabled by a user.

Important Notices when upgrading from version 5.0.2

When updating from versions prior to 5.1.2 with this Option Card installed, Eth1,
Eth2 and Eth3 will all be disabled (not accessible by the network) upon applying
this software update. If you are connected to one of these three ports to perform
the update process, the time server will not be accessible once the update has
completed. Further below is information about two different methods to enable
each of these three Interfaces as desired, after applying the software update.

14 SecureSync Software Upgrade Instructions Rev. [33]
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1.6 Hardware-Specific Steps

Because the three interfaces are disabled once the software update has com-
pleted, the network settings will appear to have been lost during the update.
However, the settings do actually persist through the update process. All of the
settings will be present again, once each interface is individually enabled.

If the software was previously updated to versions 5.1.2 or higher, the three Eth-
ernet ports will be in the same state (enabled or disabled) as they were before
applying this update.

System software version 5.1.2 added a new feature which allows unused Ethernet
interfaces (Ethl, Eth2 and/or Eth3) of the Model 1204-06 Gigabit Option Card, if
installed, to be disabled via software for security purposes. Note this change
does not apply to the base Ethernet port, "EthO”, which cannot be disabled.

After applying this software update from version 5.0.2, all three of these Ethernet
interfaces will be disabled. If any or all three of these interfaces are currently
being used, after applying the software update (or if it's desired to start using any
of these three interfaces at a later date) the desired Ethernet interface(s) needs
to be enabled. Until the interfaces have been enabled by a user, they will be inac-
cessible to the network.

Each of the three Ethernet interfaces can be enabled as desired, via either the
web browser (using the “base” Ethernet interface “EthQ”) or by issuing a specific
command with a CLI connection (telnet or SSH).

Enabling each interface using a CLI connection

After creating a CLI connection (using either telnet or SSH) the command to
enable each desired interface is as follows: portset x on (where x is the Ethernet
interface number -1, 2, or 3 - for the interface you wish to enable).

An example of enabling Interface "Eth1” is shown below:

portzet 1 on

Enabling each interface using a web browser connection

To enable each desired Interface using the web browser, login to the browser
using EthO (this interface is not disabled during the update). Navigate to the
Management -> Network page of the Web Ul. This will open a page displaying all
four Ethernet interfaces (EthO through Eth3). The Status of Ethl through Eth3
will be displayed as “DISABLED”.

For each Interface you wish to enable, click on the corresponding Gear button
(center of the three buttons in that row). In the next screen that opens, click on
the checkbox at the top of the page (as shown below). Then press either the
Apply or Submit button to enable the interface. The port will now have the pre-

SecureSync Software Upgrade Instructions Rev. [33] 15
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vious configuration as before the update was applied and will be accessible to

the network.

Edit Ethernet Port Settings

Enable eth1

DNS Primary 10.1.1.20

DNS Secondary 101.1.31
SEL 4
M Enable DHC

Edit IPvE Address

16

~ Apply
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CHAPTER 2

Upgrade Procedure

After completion of all preparation steps, the actual upgrade will be per-
formed.

Chapter 2 will guide you through this process.

Depending on which software version is currently installed in your
SecureSync unit, proceed either to:

» "Upgrading from V. 5.0.2 to a Newer Version" on the next page,

? orto "Upgrading from V. >5.1.2 to a Newer Version” on page 24.

SecureSync Software Upgrade Instructions
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2.1 Upgrading from V. 5.0.2 to a Newer Version

Note: Depending on the software currently installed on your unit,
upgrading to the latest version may be a multi-step process. See
"Determining the Correct Upgrade Procedure” on page 8 for more
information.

The software upgrade process is performed using a PC that is either on the same
network as the SecureSync appliance, or is connected directly to the SecureSync
via a network cable.

Note: In order to perform the software upgrade, the Web Ul of the
unit to be upgraded must be accessible from this particular PC.

Once you downloaded the upgrade file onto a network PC, you can then transfer
the file onto your SecureSync unit, using the unit's Web UI.

Note: Alternatively, you can also upgrade via Command Line
Interface: In this case, the file must be transferred manually, using
FTP/SFTP, to the SecureSync directory home/spectracom.

During the time that the file is being uploaded into SecureSync, the unit will
remain fully functional and accessible for other network PC's.

Once the file transfer is complete, SecureSync is performing the software
upgrade ("Upgrade System”), during which the unit is configured: Normally, all
current SecureSync configurations are automatically saved and restored as part
of the update process. During the “Upgrade System” process, the front panel
LCDs will go blank, and the unit will not be operational until the upgrade process
has completed.

1. Local Clock: After updating from the "Classic” interface only SW Version
(5.0.2) to a more recent version, you will have to create a new local clock,
and apply it to the ports as desired. It is therefore advisable to write down
any current Local Clock settings you may be using, before installing the
new software.

2. Verify that LDAP has not been ENABLED inadvertently, by navigating to
Network > LDAP Setup: If you are not using LDAP, DISABLE all services (if

18 SecureSync Software Upgrade Instructions Rev. [33]
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2.1 Upgrading from V. 5.0.2 to a Newer Version

correctly configured, the services can remain ENABLED during the
upgrade process).

Download the SecureSync upgrade file (updateXXX.tar.gz) from the
Spectracom website—see also "Downloading the Upgrade Software
Bundle" on page 12—to an accessible directory on your local Windows
machine (such as C:/Temp).

. Open the Web Ul, and login. Then navigate to Tools > Upgrade/Backup.

Logged

Usnrs

-
TIME AND FREQUENCY ——-"‘
Versions

[ Selected Time Ratarunce Sowce | (]

Ensure the Software/License Upgrade tab is orange (Orange indicates the
tab is selected). Either click in the blank text box located next to Upload
File, or select Browse to be able to select the update file (see illustration
below).

UPGRADE/BACKUP

Current Software Version

| SolwareVorsion | Spectiocom [product] Version 502 |

cense File

Use the Windows  Explorer to navigate to the location on your network PC
where the update file (updatexXX.tar.gz) was stored earlier (such as
C:/Temp), and select it. Once the path appears in the text field (see illus-
tration below), click the Upload button.

Eila
——> | upboss

. The file upload process may take several minutes. Once the file has been

uploaded, the message “The file updatexxx.tar.gz has been uploaded.”
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(where xxx is the new version being applied) will be displayed underneath
the field Upload Update/License File:

Upload Update/License File

| Upload File |[ Browse_ | Nofie selected [ Upload ‘

The file up x.tar.gz has been up

8. Now refer to the bottom of this page, under the title Upgrade the System.
Ensure the correct file name (updateXXX.tar.gz) is selected in the box
next to Update File.

Upgrade the System
| Update File | updatebXXtargz -
| Update System
| Force Update

O

| Delete Update Fils |

Restore Factory
Configuration

O

[ Submit ] [ Reset ]

9. Check the box next to Update System to install the software update.

Other available checkboxes:

Note: To perform the software update from an earlier software ver-
sion to the latest version, only the checkbox next to Update System
should be selected.

» Force Update: When checked, will force the software to install all packages,
even if it is already at the current revision, or (for example, it is desired to
install version 6.0.0, even though version 6.0.0 is already installed). The soft-
ware will reinstall over the previously installed packages.

USE CASE: This checkbox must be selected if it is ever desired to down-
grade to a previous software version.

» Delete Update File: When checked, will remove the Archive file that was

uploaded into the unit. Note that this will not remove the file from your PC,
just from SecureSync.

20 SecureSync Software Upgrade Instructions Rev. [33]
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completed.

Note: If it is desired to remove the update file from the unit
after completion of the upgrade process, note that the “Delete
the Update File” checkbox should not be selected at the same
time as the “Update System” checkbox. This process should be
performed any time after the System Update process has been

» Restore Factory Configuration: When checked, will return SecureSync to
its original factory configuration.

USE CASE: This checkbox should be selected if it is ever desired to down-
grade to a previous version (such as back to version 5.0.2, for instance).

During the System Upgrade you will see an analysis screen (as shown in the illus-

tration below).

Note: If the unit has had any previous software updates applied and
if any of the earlier upgrade files have not since been deleted from
the unit, a Web Ul screen may momentarily indicate the Upgrade
process is “Complete”. This does not affect the software update pro-
cess and the analysis screen will be displayed shortly thereafter.

UPGRADE STATUS

Analyzing...

Package Old Version MNew Version Status
Application 51.5 Analyzing
| Timing FW | 347 ‘ - | | Analyzing
| Timing FPGA | 347 ‘ . | | Analyzing
OC 11D 1F HW 01 0101 Analyzing
0C 21D 06 HW 02 0000 Analyzing
0C 31D FF HW FF 0000 Analyzing
| 0C 41D 01 HW 01 | 0103 ‘ - | | Analyzing
| 0C 51D 12 HW 01 | 0105 ‘ - | | Anayzing
OC 61D 02 HW 01 ona Analyzing
Licensing Analyzing

GNSS 0000

OC5FW B127 Analyzing

Note: “OC” being displayed in the bottom rows refers to
OPTION CARDS which may or may not be installed in your unit.

SecureSync Software Upgrade Instructions Rev. [33]
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UPGRADE STATUS

Analyzing...
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[

547

Upgrade Needed

347 |

HNo Upgrade Needed

Timing FPGA

| 37

No Upgrade Needed

OC1D1F

1M

No Upgrade Needed

OC 2 1D 06

MNo Upgrade Availabie

OC 31D FF

0000

No Upgrade Available

oc 41001

oC5ID12

0105

No Upgrade Needed

[ lceomg

oce6iD02

| 0114

No Upgrade Needed

MNo Upgrade Availabie

GNSS

No Upgrade Available

[

OC5FW

B127

Bi27

] In Progress
s ses GO

Ho Upgrade Needed

Caution: Do not close the Web Ul, or attempt to reboot the unit. The
installation is in progress and may take several minutes to complete.

SecureSync will reboot itself during the update process, as shown in the fol-
lowing screenshot:

UPGRADE STATUS
Analyzing...

| Application 5.0.2 547 | Upgrade Needed ] In Progress
[ Timing FW 347 347 | No Upgrade Needed _
| Timing FPGA 347 347 [ No Upgrade Needed | Completed
[ oCc1ID1F 0101 | 101 | Mo Upgrade Needed | compieted
0C 21D 06 0000 No Upgrade Available _
oC 31D FF 0000 : No Upgrade Available _
[ ocamn | 0103 | 103 | No Upgrade Needed _
| ocsin1z | 0105 | 1.05 | No Upgrade Needed | Completed
oC 61002 | o114 1.14 No Upgrade Needed | compeetes
Licensing Mo Upgrade Available -
GNSS 0000 No Upgrade Available _
oc5FW B127 8127 No Uparade Needed | compieted

Note: If using a DHCP assigned IP address (instead of having a stat-
ically assigned IP address), the unit’s IP address may change once
the update has completed (it may be re-assigned a different IP
address by the DHCP server). Automatic Reloading of the Web Ul
will not work if the address has been changed by the DHCP server.
Therefore, a new web browser connection using the newly assigned
|P address will need to be opened.
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2.1.1

2.1 Upgrading from V. 5.0.2 to a Newer Version

If the front panel LCD is configured to display network settings, the LCD window
will show the newly assigned IP address.

When using a static-assigned IP address (or if the DHCP server did not assign a
new IP address after the reboot), and as long the Web Ul did not time-out during
the update process (if it times-out, press the F5 key to refresh the connection),
once the update is complete, you will now see the main page of the "new"” Web Ul
design.

If you need to reconnect to the Web Ul at any point, the login screen for the new
Web Ul design will now look like the following:

@ spectracom

With the new Web Ul design, the Upgrade Log with is located in the upper-right
corner of the Home page. The top of this log should indicate “Successful”.

Upgrade Log

-~

on 13/9/14
Upgrade Initiated, Reboot Required;
fhome/spectracom/updateS0 tar.g:

Preparing Application Software for Upgrade
[SWUE)

on 13/9/14

Upgrading KTS Firmware (SWUE)

on 13/9/14
OC & 1D FF 0000 - No Upgrade Available
(SWUE)

on 13/9/14

Required Repeat of Upgrade Process

IMPORTANT: The upgrade process must be performed a second time, if you are
upgrading from a software version 5.1.4 or lower (as described in this chapter)
AND your unit is equipped with a RES-SMT-GG receiver.

This is required to update the GNSS receiver firmware.
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Note the second time performing the same update process
does require the update file be uploaded into the unit again. The
checkbox Force Update must NOT be checked.

With updateXXX.tar.gz in the update drop-down list after re-loading the
update file, just select Perform Upgrade again and click Submit. The second time
through the update process will be faster than the first time, as the receiver is the
only item updated.

2.1.2 Confirming Successful Installation

Navigate to Tools > Upgrade/Backup. The following information should now be
displayed:

System Configuration

System Speciracom SecureSync

1200-233

00000000

2.1.3 Creating new Local Clock(s)

If you previously used a Local Clock (or several), manually re-generate these
Local Clock(s), using the settings you wrote down in Step 1 above. For instruc-
tions see the main User Manual under MANAGING TIME > System Time > Local_
Clock(s).

2.2 Upgrading from V. >5.1.2 to a Newer Version

Note: Depending on the software currently installed on your unit,
upgrading to the latest version may be a multi-step process. See
"Determining the Correct Upgrade Procedure” on page 8 for more
information.
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2.2 Upgrading from V. >5.1.2 to a Newer Version

The software upgrade process is performed using PC that is either on the same
network as the SecureSync appliance, or is connected directly to the SecureSync
via a network cable.

Note: In order to perform the software upgrade, the Web Ul of the
unit to be upgraded must be accessible from this particular PC.

Once you downloaded the upgrade file onto a network PC, you can then transfer
the file onto your SecureSync unit, using the unit's Web UI.

Note: Alternatively, you can also upgrade via Command Line Inter-
face: In this case, the file must be transferred manually, using
FTP/SFTP, to the SecureSync directory home/spectracomn.

During the time that the file is being uploaded into SecureSync, the unit will
remain fully functional and accessible for other network PC's.

Once the file transfer is complete, SecureSync is performing the software
upgrade ("Upgrade System”), during which the unit is configured: Normally, all
current SecureSync configurations are automatically saved and restored as part
of the update process. During the “Upgrade System” process, the front panel
LCDs will go blank, and the unit will not be operational until the upgrade process
has completed.

1. Verify that LDAP has not been ENABLED inadvertently, by navigating to
Management > Authentication > Actions: LDAP Setup: If you are not using
LDAP, DISABLE the service (if correctly configured, the services can
remain ENABLED during the upgrade process).

2. Download the SecureSync ugrade file (updateXXX.tar.gz) from the Spec-
tracom website—see also "Downloading the Upgrade Software Bundle” on
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page 12—to an accessible directory on your local Windows machine (such
as C:/Temp).
3. Open the Web Ul, and login. Then navigate to Tools > Upgrade/Backup.

4. Click the button Update System Software in the top-left corner of the
Upgrade/Backup page:

Actions

- —
e
date Systt Software L

Upload Configuration

Restore Factory Defaults (Clean)

5. Click Browse..., and navigate to the location to which you previously saved
the update file (updatexxX.tar.gz) on your PC (such as C: /Temp). Select
the file. The file name will appear next to the Browse... button.

6. Click Upload.

Upload File

Please select a file update520 targz

1o upload:

Note: When uploading files remotely via long distances, or
when uploading multiple files via several browser windows sim-
ultaneously, the upload process may fail to complete. In this
case, cancel the upload by clicking X, and go back to Step 2.
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2.2 Upgrading from V. >5.1.2 to a Newer Version

7. The file upload process may take several minutes. Once the file has been

uploaded into your SecureSync, the directory of updatexxx.tar.gz
(where xxx is the version) will be listed in the “File” dropdown, (The “down
arrow” to the right-side of this field may need to be clicked, in order to see
the file, if previous update files have been uploaded).

Upgrade System Software

update520 tar gz
M Delete Upgrade File

W Perform Upgrade

Upload Hew File

Ensure the correct file name (updateXxX.tar.gz)!is selected in the “File”
drop-down field.

Check the box next to Perform Upgrade to install the software update (or
to downgrade to an earlier version).

Once this checkbox has been selected, two other checkboxes (Force
Upgrade and Clean Upgrade) will become visible towards the bottom of
the window. Note that these two checkboxes do not need to be selected
for a standard upgrade to a newer version.

Upgrade System Software
updatexxx targz

W Delete U File

# Perform Upgrade

Upload Hew File
Upgrade System Software

updateXxx tar.gz

M Delete Upgrade File

Perform Upgrade

W Force Upgrade (Used to upgrade fo current or lower version)

W Clean Upgrade (Check to load factory settings on upgrade)

Upload New File

TXXX: Software Upgrade Version Number

SecureSync Software Upgrade Instructions Rev. [33]
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» Force Upgrade — When checked, will force the software to install all
update packages, even if it is already at the current revision, (for example, it
is desired to install version 6.0.0, even though version 6.0.0 is already
installed). The software will reinstall over the previously installed packages.

USE CASE: This checkbox needs be selected if it is ever desired to down-
grade to a previous version of Software.

»

Clean Upgrade — When checked, will return the SecureSync to its original

factory configuration for the version of software being installed. (The Force
Upgrade checkbox will be automatically selected when the Clean Upgrade

checkbox is selected.)

Note: To perform a standard software upgrade, i.e. from an earlier
software version to the latest version, only the checkbox Perform
Upgrade needs to be selected.

Upgrade Status

In Progress

Analyzing

Application

Timing FW

Timing FPGA

OC1ID1FHW D (i)
OC 2 W 02 0000
OC 3 ID FF HW 0000
OC4IDC W0

OCSID1ZHWD

OCEID0ZHWD

Licensing

GNSS 0000

oc 5 Fw B127

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

During the System Upgrade process, the Upgrade Log window on the right-side
of the browser will periodically have new entries asserted, indicating the update

process is progressing.
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2.2 Upgrading from V. >5.1.2 to a Newer Version

Do not close the Web Ul, or attempt to reboot the unit. The
installation is in progress and may take several minutes to complete.

The Upgrade Status window will remain displayed during the upgrade progress,
as long the browser is not refreshed (such as by pressing the keyboard F5 key,
for instance) or as long as the web browser background is not clicked. If the page
happens to be refreshed or the background clicked during the next few minutes
while the update is being performed (causing the Status window to disappear),
this Status window cannot be re-opened. However, the software update will con-
tinue to be performed with the window closed (the Upgrade Status window and
the Web Ul being open are not required for the update to be performed). The
Status window will periodically report status change updates.

Note: If using a DHCP assigned IP address (instead of the unit having
a statically assigned IP address), the IP address may change once
the update has completed (it may be re-assigned a different IP
address by the DHCP server).

Automatic Reloading of the web page will not work if the address
has been changed by the DHCP server. Therefore, a new web
browser connection using the newly assigned IP address will need to
be opened.

If the front panel LCD is configured to display network settings, the LCD window
will show the newly assigned IP address.

When using a static-assigned IP address (or if the DHCP server did not assign a
new |IP address after the reboot), and as long the web browser didn’t time-out
during the update process (if it times-out, press the F5 key to refresh the con-
nection), once the update is complete, you will now see the main page of the new
web browser design.

Upgrade Log

The Upgrade Log is located in the upper-right corner of the Tools >
Upgrade/Backup page of the Web Ul. After completion of the upgrade process,
the top of this log should indicate “Successful”.
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2.2 Upgrading from V. >5.1.2 to a Newer Version

Upgrade Log

No Upgrade Available

2.2.1 Potential Need to Repeat Upgrade Process
IMPORTANT: The upgrade process must be performed a second time, if:

a. your unitis equipped with a RES-SMT-GG receiver, and you are upgrading
from a software version 5.1.4 or lower

b. OR:If your unit is equipped with a u-blox M8T receiver, and you are upgrad-
ing from a software version older than 5.5.0 .

This is required to update the receiver firmware.

Note the second time performing the same update process
does require the update file be uploaded into the time server again.
The checkbox Force Update must NOT be checked.

With updateXXxX.tar.gz! in the update drop-down list after re-loading the
update file, just select Perform Upgrade again and click Submit. The second time
through the update process will be faster than the first time, as the receiver is the
only item updated.

2.2.1.1 u-blox M8T: Upgrading to Version 6.0.0:

1. Update to software version 6.0.0.

2. The final update status page after reboot will show the u-blox M8T failed to
update to version 3.0.1 TIM 1.10.

3. Re-run the update again in order to update the u-blox M8T.

Should you see a version other than 3.0.1 TIM 1.10 displayed, the upgrade was not
successful. Proceed as follows:

TXYZ = New Software Version
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a. Reset the receiver from the Web Ul: Navigate to Interfaces > References:
GNSS Reference, and click the GEAR button next to the GNSS Reference.
In the GNSS O window, locate the Reset Receiver box, check it, and click
Submit.

b. If the version persists, reboot SecureSync.

c. Ifit still persists, run the Release 6.0.0 update again.

2.2.1.2 RES-SMT-GG: Upgrading to Version 6.0.0:

1. Update to software version 6.0.0.

2. The final update status page after reboot will show the u-blox M8T failed to
update to version 1.9,

3. Re-runthe update again in order to update the RES-SMT-GG.

Should you see a version other than 1.9 displayed, the upgrade was not suc-
cessful. Proceed as follows:

a. Reset the receiver from the Web Ul: Navigate to Interfaces > References:
GNSS Reference, and click the GEAR button next to the GNSS Reference.
In the GNSS O window, locate the Reset Receiver box, check it, and click
Submit.

b. If the version persists, reboot SecureSync.

c. Ifitstill persists, run the Release 6.0.0 update again.

2.2.2 Confirming Successful Installation

Note: You will need to log into the Web Ul, using your login account
information

Navigate to Tools > Upgrade/Backup. The new System software version should
be displayed, and the new GNSS Receiver version should be displayed (Trimble
RES-SMT-GG: SW V1.9; u-blox M8T: SW V3.0.1TIM 1.10.)

System Configuration

System Speciracom SecureSync

1200-233

Serial # 0oooooon
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Appendix

The following topics are included in this Chapter:

31 Upgrading Via ClLl oo i

3.2 Saving/Restoring Configuration Files ...
3.3 Software Update Log ENtries ...
3.4 Downgrading the SW to a Previous Version ...

3.5 "Upgrade Failure” (V. 5.0.2 to a Newer Version)
3.6 “Upgrade Failure” (V. >5.1.2 to a Newer Version)

3.7 Technical SUDDOIT L i
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3.1 Upgrading via CLI

It is possible perform a software upgrade via a Command Line Interface, rather
than using the Web Ul, for example for scripting software updates.

Starting in Archive software version 4.8.8, the software update can be initiated
using a CLI command (issued via telnet, SSH or the front panel Serial port),
instead of using the web browser, if desired. This entails performing an FTP/SCP
transfer of the software update file into SecureSync’s /home/spectracom dir-
ectory and then issuing the sysupgrade CLI command to initiate the software
upgrade.

Note: IMPORTANT: When transferring the update file using either
FTP or SCP (instead of uploading it using the web browser), make
sure the Update file is transferred using BINARY mode (SCP transfer
is preferred, because it always transfers using Binary mode). Other-
wise, this file will likely be altered during the file transfer, preventing
the updater from being able to extract it. The following error mes-
sage will be asserted into the Update log if the Update file is
altered/can’t be extracted: “ERROR (-1) - Failure while unpacking
Upgrade Bundle (SWUE)”.

The syntax for issuing the sysupgrade command is:

» Standard upgrade (Such as upgrading versions 4.8.8 to 4.8.9, for example):
“sysupgrade” followed by the upgrade file name (Example: sysupgrade
update489.tar.gz).

Forced upgrade (Such as downgrading versions 4.8.9 to 4.8.8, for example,
but can also be used with Standard upgrades, also): “sysupgrade force” fol-
lowed by the upgrade file name (Example: sysupgrade force
update489.tar.gz).

Clean upgrade (Such as first performing a Forced upgrade from 4.8.8 to
4.8.9, for example. Then automatically resetting the NTP server back to fact-
ory default settings and deleting all log files): “sysupgrade clean” followed
by the upgrade file name (Example: sysupgrade clean update489.tar.gz).

»

»
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3.2

3.3

3.4

Saving/Restoring Configuration Files

Important note about restoring old configuration files

Due to fairly significant changes to the system configuration files from system
software versions prior to version 6.0.0, it is not recommended to perform a con-
figuration restore with 6.0.0 software installed, from a configuration save that
was performed in a SecureSync with versions 4.8.9 or earlier installed. If a con-
figuration restore from versions 4.8.9 or below software is performed on a ver-
sion 5.x.x time server, a ‘clean’ will be required to be performed via the front panel
keypad thereafter to reset the NTP server to the factory default settings for the
installed version.

In general, due to possible changes to configuration files from one version to
another, if you wish to have a configuration backup file saved, we recommend
performing a new “configuration save” after each new software update is per-
formed, to replace the earlier configuration bundle. This will ensure that if a con-
figuration restore is performed, the configs in the captured file will be identical to
the ones in the NTP server.

Software Update Log Entries

Software update log entries, such as upgrades that have already been per-
formed, or an error occurring during the update process, are placed in the
Update Log (Tools > Logs page of the Web Ul). Please refer to this log if you
have any problems with the software update process (such as if the message
“Upgrade Failure” is displayed, for instance).

Downgrading the SW to a Previous Version

If your current software is below 5.9.6, the software can be downgraded to pre-
vious versions 5.0.0 or higher (it is not recommended to downgrade to versions
4.8.9 or below from versions 5.0.0 and above). The downgrade process is the
same as an upgrade, except an earlier version update bundle is selected during
the process and the update needs to be "Force Updated” (to override the version
checking that normally occurs).

SecureSync Software Upgrade Instructions
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Note: It is not possible to downgrade from 5.9.6 to any earlier ver-
sion due to significant core package updates. All versions following
5.9.6 cannot downgrade to any software version earlier than 5.9.6.

Note: Due to incompatibilities between later and earlier con-
figuration files, a “Clean Upgrade” is also required to be performed
during the software “downgrade” process (the unit will need to be
reconfigured as desired, once it's been downgraded to the desired,
earlier version).

Note: You will not be able to apply a Saved configuration file from a
later version of software to any earlier, downgraded version of soft-
ware to restore the configurations. However, a saved config file pre-
viously performed when it was at the earlier version can be safely re-
applied as desired to restore configs.

Downgrading to an earlier version using the newer (black-
/charcoal background) Web Ul:
To simultaneously downgrade and ‘Restore Factory Configuration”:

1. Navigate to the Tools > Upgrade/Backup page.

2. Press Update System software (on the left side of the screen, under
Actions).

3. Verify the desired update bundle you wish to downgrade to is in the File
drop-down. If not, press Upload New File and browse to where the earlier
update bundle is stored. Upload the bundle into the unit,

4. Select the Perform Upgrade checkbox in the menu that opens, which will
expand the menu down to display two additional checkboxes.

5. Select the desired Update bundle version which you wish to downgrade to.
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6. Select also the Force Upgrade and Clean Upgrade checkboxes, before click-
ing Submit (as shown in the screenshot below) to begin the
downgrade. The Clean Upgrade checkbox resets all of the configurations
back to factory default, as needed to occur when downgrading to an earlier
software version.

The software downgrade will take several minutes to complete.

Note: If the software was downgraded back to a version prior
to version 5.1.0, the “classic interface” will be displayed after
logging back in, once the downgrade has completed.

Upgrade System Software

updateﬁn

pdate502 tar.gz

e

] Force Upgrad 0 upgrade to current or lower version)
Force Upg to upgrade t it or | )

Clean Upgrade { K to load factory settings on upgrade)

Upload New File

1. Once downgraded, reconfigure the unit’s settings as desired, or restore a
previously Saved config file from the version the software has been down-
graded to.

Downgrading to an earlier version using the “classic interface”
Web Ul

To simultaneously downgrade and Restore Factory Configuration, in addition to
selecting the Update System, and Force Update checkboxes, also select the
Restore Factory Configuration checkbox before clicking Submit (as shown in the
screenshot below). The software downgrade will take several minutes to com-
plete.

The Restore Factory Configuration checkbox resets all of the unit’'s con-
figurations back to the factory default settings.
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Note: If the software was downgraded back to a version prior to ver-
sion 5.1.2, the “classic” interface will be displayed after logging back
in, once the downgrade has completed.

UPGRADE/BACKUP

Currant Software Version

" RPN RCAREC e 1
| Uoad Fla I '
& Degradathe Systam : Select the “Update System™, the “Force
I ot ER gt o s 28 Update™ and the “Restore Factory
) o Configuration” check-boxes when
n:.“f"‘- — rE downgrading to any previous version
A '04-‘_ (such as downgrading from version 5.0.2
B to version 4.8.9, for example).

Reconfigure the settings as desired, or restore a previously saved config file from
the version the software has just been downgraded to.

3.5 “Upgrade Failure” (V. 5.0.2 to a Newer Version)

If the Update process returns “Upgrade Failure” (as shown below), the software
update process was not successful.

UPGRADE STATUS

Upgrads Failure
| Package | odwersen | Newwrsen | _acton Stann
Apphcation SW | P . Anatyiing

Timing S - = Ansiyzing

If this happens, review the entries in the Update and System logs.

Applying the same version already installed or downgrading to an earlier version
of software without select the “Force Update” checkbox, in addition to selecting
the “Update System” checkbox can cause the upgrade to fail. Make sure to select
“Force update when applying the same or earlier version of software.

The Update log may contain the following entry: “Error (-1) Failure while unpack-
ing Upgrade Bundle” / “Problem unpacking NWP bundle” (as shown below):
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LOG FILES

Timestamps are in system timescale (UTC)

| Event || Alarms || Oscillator || GPS Gualification || NTP || Journal || Authentication || Update || Timing || System |

Nov 11 17:15:50 PSC-SecureSync FSC—EewreSync [sw-upgrade] SW Upgrade Emor (8) (SWUE)

Now 11 17:15:48 PSC- PS ERROR (-1) - Failure while unpacking Upgrade Bundle {SWUE)
Now 11 17:15:40 PSC FSC : ERROR (-1) - Problem unpacking NWP bundle (SWUE)

MNow 11 17:14:51 PSC PSC Starting Update (SWUE)

MNaw 8 22:35:22 PSC-SecureSyne FSCSeellESync [sw-upgrade] SW Upgrade Error () (SWUE)

MNaw8 22:35:21 PSC ERROR (1) - Failure while unpacking Upgrade Bundle (SWUE)
Naw8 22:35:21 PSC FSC ERROR (1) - Problem unpacking NWP bundie (SWUE)

Naw8 22:34:25 PSC PSC Starting Update (SWUE)

Nov8 22:28:04 PSC-SecureSync PSC-SecureSync: [sw-upgrade] SW Upgrade Emor (8) (SWUE)

Likely causes for this error message in the Update log

?» The update file may be corrupt (preventing it from being able to be extrac-
ted in the time server). Run MD5 checker against the update file to verify
file integrity. Spectracom provides the MD5 file for each software update
file.

» Too many Update Bundles are stored in the time server. Delete previous
update bundles (such as update489, for instance).

Once a software update has been applied, the update bundle can be deleted (the
bundles only need to be stored in the time server to alleviate the need to transfer
them again to perform a software downgrade. Otherwise, they can be safely
deleted without affecting the time server). Having too many upgrade files saved
can prevent the update file being applied from being able to extract.

To delete earlier update files, select each one individually in the drop-down,
check only the "Delete Update File” checkbox in the screen where you normally
select “Update File”. Then press Submit. This will delete the selected update file.
Then run the update process again.
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UPGRADE/BACKUP

Current Software Version
|| SobwamVemion || Spocacom MerClock 881 Verion 800 |

Upload UpdateLicense File

[ Brmwse ) [_pions ]|

3.6 “Upgrade Failure” (V. >5.1.2 to a Newer Version)

If the Update process returns “Upgrade Failure” (as shown below), the software
update process was not successful. Note that starting the update process again
after it is already been started will result in an “upgrade failure” of the subsequent
update process, while the first one is still being performed in the background.
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Upgrade Status

In Progress

Upgrade Failure

Applic:

Licensing

If this happens, review the entries in the Update and System logs.

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

APPENDIX

1. The time server may be retaining earlier upgrade bundle files which were

applied and are no longer needed. Previous update bundles should be

deleted. For more information, see "Deleting Old Update Files” on page 11.

2. Applying the same version already installed or downgrading to an earlier
version of software without select the “Force Update” checkbox, in addi-
tion to also selecting both the “Force Upgrade” and “Clean Upgrade” check-

boxes can cause the upgrade to fail. Make sure to select the “Perform

Upgrade”, “Force Upgrade” and “Clean Upgrade” checklboxes when apply-

ing the same or earlier version of software.

3. The Update log may contain the following entry: “Error (-1) Failure while

unpacking Upgrade Bundle” / “Problem unpacking NWP bundle”

Likely causes for this error message in the Update log:

” The update file may be corrupt (preventing it from being able to be extrac-
ted in the time server). Run MD5 checker against the update file to verify
file integrity. Spectracom provides the MD5 file for each software update
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file.

”» Too many Update Bundles are stored in the time server. Delete previous
update bundles (such as update489, for instance).

Once a software update has been applied, the update bundle can be deleted (the
bundles only need to be stored in the time server to alleviate the need to transfer
them again to perform a software downgrade. Otherwise, they can be safely
deleted without affecting the time server). Having too many upgrade files saved
can prevent the update file being applied from being able to extract.

To delete earlier update files, select each one individually in the drop-down,
check only the checkbox Delete Upgrade File in the screen where you normally
select “Update File”. Then click Submit. This will delete the selected update file.
Then run the update process again.

Upgrade System Software

File

/nomefspeciracom/update50g |

Delete Upgrade File

Upload New File

Failure of Component Upgrades

Certain conditions may cause your overall upgrade status to be listed as Com-
plete, even though some components show Failed upgrades.
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In Progress

Complete

Mo Upgrade
Available

Mo Upgrade
Povailalde

Mo Upgprade:
HPoailable

Mo Upgrade
Povailaabile

In Progress

Mo Uipgrade
Available

Note: One known cause of this problem is in units currently running
software version 5.8.3 through 5.8.7 with option cards 1204-01,
1204-02,1204-03,1204-04, 1204-05, 1204-15, or 1204-23 installed
and active, and upgrading to a newer version.

If a component such as an option card fails your first attempt at upgrade:

» Upload the upgrade file again

» Repeat upgrade

» Note component status

If all Failed messages have cleared, the update has been successful with all expec-

ted materials.

If you receive additional Failed messages, it is recommended that you contact

Technical support for additional insturction or infomation.
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3.7 Technical Support

To request technical support and more information for your SecureSync unit,
please go to the "Timing Support” page of the Safran Navigation & Timing welb-
site, where you can not only submit a support request, but also find additional
technical documentation:
(https://safran-navigation-timing.com/support-hub).

Phone support is available during regular office hours under the telephone num-
bers listed below.

To speed up the diagnosis of your SecureSync, please send us:

» the current product configuration (see "Option Card Identification” on
page 1to find out which option cards are installed in your unit), and

? the events log (see "Saving and Downloading Logs” on page 1).

Thank you for your cooperation.

3.7.1 Regional Contact

Safran operates globally and has offices in several locations around the world.
The (formerly Orolia/Spectracom) main offices are listed below:

Table 3-1: Safran contact information
Country Location Phone Address

France Les Ulis +33(0)164 533980 | Safran Trusted 4D SAS
Parc Technopolis - Bat. Sigma
3, Avenue du Canada

91974 Les Ulis Cedex

USA West Henrietta, NY | +1585 3215800 Safran Trusted 4D Inc.

45 Becker Rd, Suite A

West Henrietta, NY 14586
Additional regional contact information can be found on the Contact page of the
Safran website (https://safran-navigation-timing.com/contact).

xii SecureSync Software Upgrade Instructions
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