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Upgrade Preparations

Chapter 1 guides you through the steps necessary to prepare the
upgrade.

The following topics are included in this Chapter:

1.1 Determining the Current System Software ............. 6
1.2 Determining the Correct Upgrade Procedure .......... 8
1.3 Freeing up Disk Space .................................. 8
1.4 Downloading the Upgrade Software Bundle ... 11
1.5 Hardware-Specific Steps _.............................. 12
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1.1 Determining the Current System Software ‘ speCtracom

1.1 Determining the Current System Software

First, determine which system software version is currently installed on your NetClock 9400:

1.1.1  Using Version 5.1.2 and Above
1. Inthe NetClock 9400 Web User Interface (Web Ul), navigate to Tools > System:

Upgrade/Backup.
SYSTEM LOGS

Alarms
Autharization
Events
Journal

NTP
Oscillator

System Configuration

System

Model

2. Take note of the system software version number.

1.1.2  Using Version 5.0.2 and Below ("Old Style" Web Ul

1. Inthe Web Ul, navigate to Tools > Versions.

[statws o[Sewp « Network

UPGRADE/BACKUP Versians
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2. Take note of the Archive Version number.




1.2 Determining the Correct Upgrade Procedure ‘ speCtracom

1.2 Determining the Correct Upgrade Procedure

There are three possible upgrade scenarios:

| If your currently installed software is Version 5.0.2 or higher, proceed to
"Upgrade Procedure" on page 17.

Il. If your currently installed software is Version 5.0.1 or lower and 4.8.9 or higher: You must
install Version 5.0.2 first, and then the latest version. To download the 5.0.2 software
bundle (includes instructions), navigate to
http: //spectracom.com/support/securesync-and-netclock-2400-support.

lIl. If your currently installed software is Version 4.8.8 or lower, you must install Version 4.8.9
first, 5.0.2 second, and then the latest version. To download the 4.8.9 and 5.0.2 soft
ware bundles (includes instructions), navigate to
http: //spectracom.com/support/securesync-and-netclock-2400-support.

<488 *5;| 2502

install new reIeaseJ

J

With all three scenarios, before beginning with the actual software installation, you must first
complete all necessary steps in CHAPTER 1.

If you download more than one file, the files will be bundled into one compressed file that you
need to extract, once it has been downloaded. Thereafter, only upload the file upda-
texxx.tar.gz (where xxx = software version) to the unit to be upgraded.

1.3 Freeing up Disk Space
NetClock 9400 uses a Compact Flash (CF) memory card for storing logs, configurations and

software. Over time, the Compact Flash card can contain many log entries and any previous
software update files retained from earlier software updates.

8 CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17]
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‘ SpeCtrocom 1.3 Freeing up Disk Space

If the CF card usage is higher than normal when a software update is performed, this can
potentially result in the loss of some or all of the unit's configurations upon completion of the
software update process or may prevent the update from being able to begin. It may be neces-
sary for the unit's logs and previous update files to be deleted before performing software
updates.

The logs can be backed-up to a single bundled fine and then exiracted before deleting them, if
required by your organization. The processes to easily delete logs and previous Update files
before updating the software is described within.

Note: An available CLI command (df —h) can be used to read what percentage of
the CF card is currently in use, fo determine if the logs and update files should be
deleted. In general, if the CF card usage is more than around 70 % or so, the

logs and any previous software update files should be deleted to ensure there is
plenty of space in the CF card to persist the config files and to be able to perform
the upgrade.

1.3.1  Determining Current Disk Usage

There are two ways to defermine the usage, via the Web Ul, or using the Command Line Inter-
face (CLI):
Determining Disk Usage via the Web Ul

1. In the Web Ul, navigate to TOOLS > SYSTEM: Upgrade/Backup.

2. In the Disk Status panel in the bottom-left corner of the screen, the Percent value indicates
what percentage of disk space is currently used.

Determining Disk Usage via the CLI

Login to the CLI (telnet or ssh) and at the command prompt, type: df —h <enter> (as shown
below). The “Use%" column in the “/dev/hda1” row will indicate the CF card usage (65 % in
this example, which indicates the logs and any previous Update files do not need to be deleted
before performing the update process.)

CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17] 9



1.3 Freeing up Disk Space ‘ SpeCtrocom

1.3.2  Archiving and Deleting Log Files

If the disk usage is higher than 70% (approximately), Spectracom recommends that you delete
the logs and update files that may have been previously applied before performing the system
software upgrade.

Archiving Logs

As an option, the logs can be archived (backed up) before deletion, by bundling them into a
single file, and then transferring them to your PC, all from within the NetClock 400 Web UI.

To archive logs:
1. In the Web Ul, navigate to MANAGEMENT > OTHER: Log Configuration.

2. Click on Save and Download All Logs. This will generate a single bundled file (* . 10g)
of the logs. Select where to save this file on your PC.

Deleting Logs and Statistics

To delete log files and statistics files, in order to cleanup disk space:
1. Inthe Web Ul, navigate to TOOLS > SYSTEM: Upgrade/Backup.

2. In the bottom-left corner of the screen, take note of the Percent value, indicating how
much disk space is currently used.

3. Then click on Clear All Logs, and then Clear All Stats below.

4. After completion of the process, the Percent value should show a smaller number, indic-
ating how much disk space was cleared.

1.3.3  Deleting Old Update Files

Update files used in previously executed software upgrades are stored in the home /spec-
tracom directory. You can delete them individually via the Web Ul (they are no longer used
by the System, after the update has been applied).

To delete each update file:

10 CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17]



‘ speCtracom 1.4 Downloading the Upgrade Software Bundle

1.3.4

1.4

1. Inthe Web Ul, navigate to Tools > Upgrade/Backup (see illustration below):

INTERFACES

System Configuration

2. Click on the button Update System Software in the top-left corner. The Upgrade System
Software window will open (see illustration below):

Upgrade System Software

Delete Upgrade File

Upload New File

3. The drop-down list will display each update file currently stored in the NetClock 9400
Compact Flash Card. Select the file to be deleted, and check the Delete Upgrade File
checkbox. Then click Submit.

4. Repeat this process to delete any other listed update file.

Disk Cleanup Patch

Under some circumstances, clearing logs and stats conventionally via the Web Ul (as described
above) will require a second step in order fo achieve an optimum restoration of disk space.

To this end, Spectracom provides a Disk Cleanup Patch that can be downloaded with instruc-
tions from https: //files.spectracom.com/public-  downloads/updatecleaner-
securesyncnetclock-2400, and run from within the Web Ul. This Patch will clean items that
are not user accessible otherwise.

Downloading the Upgrade Software Bundle

The new version system software upgrade (as well as previous versions, if needed) can be
downloaded from the Spectracom Corporate website, see:

CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17] 11
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1.5 Hardware-Specific Steps ‘ SpeCtrccom

Spectracom Support page for NetClock

» Download the file(s) onto your PC, and note the location. If you download more than
one file, the files will be bundled in a compressed file that needs to be extracted after

download. Then, only upload the file updatexxx.tar.gz to the unitto be
upgraded (where xxx = software version).

1.5 Hardware-Specific Steps

With certain hardware configurations and options (see below), the corresponding procedures
described below must be carried out when upgrading from Versions 5.0.2 or higher to Version

5.8.4.

These instructions apply only, if one or several of these options are installed:
» Trimble RES-SMT-GG Receiver
» 10/100 PTP Option
» Gigabit Ethernet Option

Please note that these option-related procedures must be carried out only once, i.e. if you have
previously upgraded your system from Version 5.0.2 to e.g., 5.1.5, you can skip this section.

1.5.1  Trimble RES-SMT-GG Receiver and u-blox M8T Receiver

Units shipped between 2Q 2014 and 3Q 2016 typically have a RES-SMT-GG GNSS receiver
installed, while units built thereafter are equipped with a u-blox M8T receiver.

With either receiver, it may be necessary to execute the installation procedure twice in order to
install not only the NetClock 9400 system software update, but also a GNSS receiver firmware
update:

a. If your unit has a RES-SMT-GG receiver, AND you are upgrading from a version less
than 5.1.5 to a higher version.

» When upgrading from version 5.0.2 to 5.1.5 or higher, see "Required Repeat of
Upgrade Process" on page 23.

» When upgrading from version 5.1.2 to 5.1.5 or higher, see "Potential Need to
Repeat Upgrade Process" on page 29.

b. If your unit includes a u-blox M8T receiver, AND you are upgrading from version 5.5.0
or lower to 5.6.0 or higher.

» See "Potential Need to Repeat Upgrade Process" on page 29.

ﬂ Note: In cases other than the ones described above, the firmware update will be

skipped automatically.

12 CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17]
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1.5.1.1  Determining the GNSS Receiver
Next, you need to determine which type of GNSS receiver is installed in your NetClock 9400.

ﬂ Note: If the default Web Ul of your unit is blue/white (rather than dark grey),

your unit has a receiver.

1. If your Web Ul is dark grey (see illustration below), navigate to Interfaces -> GNSS 0.
The first line item under the default Main tab will report the GNSS receiver Model that is
installed in your NetClock 9400. The example shown in the illustration below shows a
"RES-SMT GG" receiver.

@ Main i Satellite Data

2. Take note of the receiver type installed in your unit.

When there are software updates that need to be automatically applied to the 10/100 PTP
Option during the upgrade process, the upgrade process will take an additional 5 to 7 minutes
longer, for each 10/100 PTP Option Module that is installed.

1.5.2  Gigabit Ethernet Option

ﬂ Note: This section is not applicable when previously upgrading from versions

5.1.2 and above and the Ethernet ports have already been enabled by a user.

Important Notices when upgrading from version 5.0.2

When updating from versions prior to 5.1.2 with this Option installed, Eth1, Eth2 and Eth3 will
all be disabled (not accessible by the network) upon applying this software update. If you are
connected to one of these three ports to perform the update process, the time server will not be
accessible once the update has completed. Further below is information about two different
methods to enable each of these three Interfaces as desired, after applying the software
update.

Because the three interfaces are disabled once the software update has completed, the network
seftings will appear to have been lost during the update. However, the settings do actually per-
sist through the update process. All of the settings will be present again, once each interface is
individually enabled.

CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17] 13



1.5 Hardware-Specific Steps ‘ SpeCfrCICOm

If the software was previously updated to versions 5.1.2 or higher, the three Ethernet ports will
be in the same state (enabled or disabled) as they were before applying this update.

System software version 5.1.2 added a new feature which allows unused Ethernet inferfaces
(Eth1, Eth2 and/or Eth3) of the Gigabit Option , if installed, to be disabled via software for
security purposes. Note this change does not apply to the base Ethernet port, “EthO”, which
cannot be disabled.

After applying this software update from version 5.0.2, all three of these Ethernet interfaces will
be disabled. If any or all three of these interfaces are currently being used, after applying the
software update (or if it's desired to start using any of these three interfaces at a later date) the
desired Ethernet interface(s) needs to be enabled. Until the interfaces have been enabled by a
user, they will be inaccessible to the network.

Each of the three Ethernet interfaces can be enabled as desired, via either the web browser
(using the “base” Ethernet interface “EthO”) or by issuing a specific command with a CLI con-
nection (telnet or SSH).

After creating a CLI connection (using either telnet or SSH) the command to enable each
desired interface is as follows: portset x on (where x is the Ethernet interface number - 1, 2, or
3 - for the interface you wish to enable).

An example of enabling Interface “Eth1” is shown below:

padminBESpectracom portzet 1 on
padmin@Spectracom

Enabling each interface using a web browser connection

To enable each desired Interface using the web browser, login to the browser using EthO (this
interface is not disabled during the update). Navigate to the Management -> Network page of
the Web Ul. This will open a page displaying all four Ethernet interfaces (EthO through Eth3).
The Status of Eth1 through Eth3 will be displayed as “DISABLED”.

For each Interface you wish to enable, click on the corresponding Gear button (center of the
three buttons in that row). In the next screen that opens, click on the checkbox at the top of the
page (as shown below). Then press either the Apply or Submit button to enable the interface.
The port will now have the previous configuration as before the update was applied and will
be accessible to the network.

14 CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17]
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Edit Ethernet Port Settings

Enable eth1

DMNS Primary 10.1.1.20

DNS S dary 10.1.1.31

Enable CPvd

. Enable DHCPv6

. Enable SLA

Edit IPvE Address

CHAPTER 1 e NetClock 9400 Software Upgrade Instructions Rev. [17]

1.5 Hardware-Specific Steps

15



BLANK PAGE.




QN
a%d
L1
—
am
<
1L
O

Upgrade Procedure

After completion of all preparation steps, the actual upgrade will be
performed.

Chapter 2 will guide you through this process.

Depending on which software version is currently installed in your
NetClock 9400 unit, proceed either to:

» "Upgrading from V. 5.0.2 to New Version" on the next page,

» or to "Upgrading from V. >5.1.2 to New Version" on
page 24.

CHAPTER 2 ® NetClock 9400 Software Upgrade Instructions
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2.1 Upgrading from V. 5.0.2 to New Version ‘ SpeCtrccom

2.1 Upgrading from V. 5.0.2 to New Version

The software upgrade process is performed using a Windows PC that is either on the same net-
work as the NetClock 9400 appliance, or is connected directly to the NetClock 9400 via a net
work cable.

ﬂ Note: In order to perform the software upgrade, the Web Ul of the unit to be

upgraded must be accessible from this particular PC.

Once you downloaded the upgrade file onto a network PC, you can then transfer the file onto
your NetClock 9400 unit, using the unit's Web Ul

Note: Alternatively, you can also upgrade via Command Line Interface: In this
case, the file must be transferred manually, using FTP/SFTP, to the NetClock 9400

directory home / spectracom.

During the time that the file is being uploaded into NetClock 9400, the unit will remain fully
functional and accessible for other network PC's.

Once the file transfer is complete, NetClock 9400 is performing the software upgrade
("Upgrade System"), during which the unit is configured: Normally, all current NetClock 9400
configurations are automatically saved and restored as part of the update process. During the
“Upgrade System” process, the front panel LCDs will go blank, and the unit will not be oper-
ational until the upgrade process has completed.

1. Local Clock: After updating from the "Classic" inferface only SW Version (5.0.2) to a
more recent version, you will have to create a new local clock, and apply it to the ports
as desired. It is therefore advisable to write down any current Local Clock settings you
may be using, before installing the new software.

2. Verify that LDAP has not been ENABLED inadvertently, by navigating to Network >
LDAP Setup: If you are not using LDAP, DISABLE all services (if correctly configured, the
services can remain ENABLED during the upgrade process).

‘‘‘‘‘‘
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‘ SpeCtracom 2.1 Upgrading from V. 5.0.2 to New Version

3. Download the NetClock 9400 upgrade file (updateXXX.tar.gz) from the Spec-
tracom website—see also "Downloading the Upgrade Software Bundle" on page 11—

to an accessible directory on your local Windows machine (such as C: / Temp).

4. Open the Web Ul, and login. Then navigate to Tools > Upgrade/Backup.

Logged
Status Setup Network [Tools

Users
Notification

TIME AND FREQUENCY STATU =
=

nnnnnn

| Selected Time Reference Source [ Gps ComtactRegister

5. Ensure the Software/License Upgrade tab is orange (Orange indicates the tab is selec-
ted). Either click in the blank text box located next to Upload File, or select Browse to be
able to select the update file (see illustration below).

UPGRADE/BACKUP

| sonwareiLicense uparade ||

Current Software Version

‘ e e ‘ Spectracom [product] Version 5.0.2 |

‘ Upload File

6. Use the Windows® Explorer to navigate to the location on your network PC where the
update file (updateXXxX. tar.gz) was stored earlier (such as C: /Temp), and select
it. Once the path appears in the fext field (see illustration below), click the Upload but-
ton.

Upload Update/Lij i
‘ Upload File [ Biow€_[ vposicsuctar gz ‘

7. The file upload process may take several minutes. Once the file has been uploaded, the
message “The file updatexxx.tar.gz has been uploaded.” (where xxx is the new version
being applied) will be displayed underneath the field Upload Update/License File:

Upload Update/License File

| Upload File [ Browse_ ] nofie selected [ Upload ‘

The file update5ixx.tar.gz has been uploaded.

8. Now refer to the bottom of this page, under the title Upgrade the System. Ensure the cor-
rect file name (updateXxXX.tar.qgz) is selected in the box next to Update File.

CHAPTER 2 e NetClock 9400 Software Upgrade Instructions Rev. [17] 19



2.1 Upgrading from V. 5.0.2 to New Version ‘ SpeCtrqcom

Upgrade the System

Update File | updatebxxtargz -

| Update System
| Force Update

o oo

| Delete Update File |

Restore Factory
Configuration

[ Submit ] [ Reset ]

9. Check the box next to Update System to install the software update.

Other available checkboxes:

ﬂ Note: To perform the software update from an earlier software version to the

latest version, only the checkbox next to should be selected.

» Force Update: When checked, will force the software to install all packages, even if it is
already at the current revision, or (for example, it is desired to install version 5.8.4,
even though version 5.8.4 is already installed). The software will reinstall over the pre-
viously installed packages.

USE CASE: This checkbox must be selected if it is ever desired to downgrade to a pre-
vious software version.

» Delete Update File: When checked, will remove the Archive file that was uploaded into
the unit. Note that this will not remove the file from your PC, just from NetClock 9400.

Note: If it is desired to remove the update file from the unit after completion
of the upgrade process, note that the “Delete the Update File” checkbox
should not be selected at the same time as the “Update System” checkbox.

This process should be performed any time after the System Update pro-
cess has been completed.

» Resfore Factory Configuration: When checked, will return NetClock 9400 to its original
factory configuration.

USE CASE: This checkbox should be selected if it is ever desired to downgrade to a pre-
vious version (such as back to version 5.0.2, for instance).

During the System Upgrade you will see an analysis screen (as shown in the illustration below).

20 CHAPTER 2 e NetClock 9400 Software Upgrade Instructions Rev. [17]
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2.1 Upgrading from V. 5.0.2 to New Version

Note: If the unit has had any previous software updates applied and if any of the
earlier upgrade files have not since been deleted from the unit, a Web Ul screen
may momentarily indicate the Upgrade process is “Complete”. This does not

affect the software update process and the analysis screen will be displayed
shortly thereafter.

UPGRADE STATUS

Analyzing...

Package Old Version New Version Action Status
Application 51.5 Analyzing
‘ Timing FW | 347 ‘ | | Analyzing
‘ Timing FPGA | 347 ‘ | | Analyzing
OC1ID1FHWOM 010 Analyzing
0OC 21D 06 HW 02 0000 Analyzing
OC 31D FF HW FF 0000 Analyzing
| 0OC 41D 01 HW 01 | 0103 ‘ | | Analyzing
| 0C 51012 HW 01 | 0105 ‘ | | Anayzing
OC6ID0ZHW O 0114 Analyzing
Licensing Analyzing

GNSS 0000

OC5FW B127 Analyzing

Note: “OC" being displayed in the bottom rows refers to

may or may not be installed in your unit.

OPTION CARDS which

Package
Application
Timing FW
Timing FPGA
OC 11D 1F
OC 21D 06
OC 31D FF
oc 41001
0CsInI2
OCEID02
Licensing

GNSS
oCSFW

‘Old Version
5.0.2

37
0101
0000
0000
0103
0105

0114

0000
B127

UPGRADE STATUS
Analyzing...
| newverson | Action
[ 547 [ Upgrade Needed
347 No Upgrade Needed
347 No Upgrade Needed
101 Mo Upgrade Needed
No Upgrade Available
No Upgrade Available
1.03 No Upgrade Needed
105 No Upgrade Needed
1.14 No Upgrade Needed
No Upgrade Available

B127

No Upgrade Available

No Upgrade Needed

Status

In Progress

Caution: Do not close the Web Ul, or attempt to reboot the unit. The installation is

in progress and may take several minutes to complete.

CHAPTER 2 e NetClock 9400 Software Upgrade Instructions Rev. [17]
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2.1 Upgrading from V. 5.0.2 to New Version ‘ SpeCtrqcom

NetClock 9400 will reboot itself during the update process, as shown in the following screen-

shot:
UPGRADE STATUS
Analyzing...

Package Old Version MNew Version Action [ Status
Application 5.0.2 547 Upgrade Needed In Progress
Timing FW 347 347 No Upgrade Needed _

Timing FPGA 317 3a7 No Upgrade Needed _
0C 11D 1F 0101 1.01 No Upgrade Needed | completea
oc 21006 0000 . No Upgrade Available | Completed
0C 3IDFF 0000 : ' No Upgrade Available | completed
OC 41D 01 0103 1.03 No Upgrade Needed _
0C 51012 0105 1.05 No Upgrade Needed | Compieted
0Cc 61D 02 0114 114 No Upgrade Needed | completed

Licensing No Upgrade Available | Compieted

GNSS 0000 . [ No Upgrade Available | completed
0C 5FW B127 B127 No Upgrade Needed | compieted

Nofe: If using a DHCP assigned IP address (instead of having a statically
assigned IP address), the unit's IP address may change once the update has com-
pleted (it may be re-assigned a different IP address by the DHCP server). Auto-

matic Reloading of the Web Ul will not work if the address has been changed by
the DHCP server. Therefore, a new web browser connection using the newly
assigned IP address will need to be opened.

If the front panel LCD is configured to display network settings, the LCD window will show the
newly assigned IP address.

When using a static-assigned IP address (or if the DHCP server did not assign a new IP address
after the reboot), and as long the Web Ul did not time-out during the update process (if it times-
out, press the F5 key to refresh the connection), once the update is complete, you will now see
the main page of the "new" Web Ul design.

If you need to reconnect to the Web Ul at any point, the login screen for the new Web Ul
design will now look like the following:

@ spectracom

With the new Web Ul design, the Upgrade Log with is located in the upper-right corner of the
Home page. The top of this log should indicate “Successful”.

22 CHAPTER 2 o NetClock 9400 Software Upgrade Instructions Rev. [17]
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2.1.1

2.1.2

Upgrade Log

" sucessful
) on 13/9:14
u |:|_g rade Initiated, Reboot Required
Mmome/spectracom/updates01 tar.c UAL)
14
Preparing Application Software for Upgrade
(SWUE)
on 13/9:14
Upgrading KTS Firmware (SWUE)
on 13/9:14
OC & 1D FF 0000 - No Upgrade Available
(SWUE)

on 13/9/14

Required Repeat of Upgrade Process

IMPORTANT: The upgrade process must be performed a second time, if you are upgrading
from a software version 5.1.4 or lower (as described in this chapter) AND your unit is equipped
with a RES-SMT-GG receiver.

This is required to update the GNSS receiver firmware.

Caution: Note the second time performing the same update process does require
the update file be uploaded into the unit again. The checkbox must
NOT be checked.

With updateXxX.tar.gz in the update drop-down list after re-loading the update file, just
select Perform Upgrade again and click Submit. The second time through the update process will
be faster than the first time, as the receiver is the only item updated.

Confirming Successful Installation
Navigate to Tools > Upgrade/Backup. The following information should now be displayed:

System Configuration

Sysiem Speciracom SecureSync

1200-233

Serial # 00000000
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2.1.3  Creating new Local Clock(s)

If you previously used a Local Clock (or several), manually re-generate these Local Clock(s),
using the settings you wrote down in Step 1 above. For instructions see the main User Manual

under MANAGING TIME > System Time > Local Clock (s).

2.2  Upgrading from V. >5.1.2 to New Version

The software upgrade process is performed using a Windows PC that is either on the same net-
work as the NetClock 9400 appliance, or is connected directly to the NetClock 9400 via a net
work cable.

upgraded must be accessible from this particular PC.

ﬂ Note: In order to perform the software upgrade, the Web Ul of the unit to be

Once you downloaded the upgrade file onto a network PC, you can then transfer the file onto
your NetClock 9400 unit, using the unit's Web Ul

Note: Alternatively, you can also upgrade via 2 In this
case, the file must be transferred manually, using FTP/SFTP, to the NetClock 9400

directory home / spectracom.

During the time that the file is being uploaded into NetClock 9400, the unit will remain fully
functional and accessible for other network PC's.

Once the file transfer is complete, NetClock 9400 is performing the software upgrade
("Upgrade System"), during which the unit is configured: Normally, all current NetClock 9400
configurations are automatically saved and restored as part of the update process. During the
“Upgrade System” process, the front panel LCDs will go blank, and the unit will not be oper-
ational until the upgrade process has completed.

1. Verify that LDAP has not been ENABLED inadvertently, by navigating to Management >
Authentication > Actions: LDAP Setup: If you are not using LDAP, DISABLE the service (if
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correctly configured, the services can remain ENABLED during the upgrade process).

I“_— S c -

Users

LDAP Setup

»
T WA Sewp— |

. Change My Password

Change My Password

2. Download the NetClock 9400 ugrade file (updateXxx.tar.gz) from the Spec-
tracom website—see also "Downloading the Upgrade Software Bundle" on page 11—

to an accessible directory on your local Windows machine (such as C: / Temp).

3. Open the Web Ul, and login. Then navigate to Tools > Upgrade/Backup.

Marms
AAhorzasn
Evirits
Joumal
Moage 209012 NP

O illlod
Cusitcaton
Sruen
Tirming
Uipdate

page:

Save Configuration
Restore Configuration

Upload Configuration

Restore Factory Defaults (Clean)

* Clean Configuration and Halt *

5. Click Browse..., and navigate to the location to which you previously saved the update

file (updateXxx.tar.gz) onyour PC (such as C: /Temp). Select the file. The file
name will appear next to the Browse... button.

6. Click Upload.
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Upload File

e update520 targz

1o upload:

Note: When uploading files remotely via long distances, or when upload-
ing multiple files via several browser windows simultaneously, the upload
process may fail o complete. In this case, cancel the upload by clicking X,
and go back to Step 2.

7. The file upload process may take several minutes. Once the file has been uploaded into
your NetClock 9400, the directory of updatexxx.tar.gz (where xxx is the version)
will be listed in the “File” dropdown, (The “down arrow” to the right-side of this field
may need to be clicked, in order to see the file, if previous update files have been
uploaded).

Upgrade System Software

update520.1ar.gz

M Delete Upgrade File

W Perform Upgrade

Upload Hew File

8. Ensure the correct file name (updatexxx.tar.gz)! is selected in the “File” drop-
down field.

9. Check the box next to Perform Upgrade to install the software update (or to downgrade
to an earlier version).
Once this checkbox has been selected, two other checkboxes (Force Upgrade and Clean
Upgrade) will become visible towards the bottom of the window. Note that these two
checkboxes do not need to be selected for a standard upgrade to a newer version.

1XXX: Software Upgrade Version Number
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Upgrade System Software

updaiexxx targz

[ Delete Upgrade File

¥ Perform Upgrade

Upload Hew File

Upgrade System Software

updatex:Citargz
M Delete Upgrade File
Perform Upgrade
B Force Upgrade (Used to upgrade to current or lower version)

W Clean Upgrade (Check to load factory settings on upgrade)

Upload New File

» Force Upgrade — When checked, will force the software to install all update packages,
even if it is already at the current revision, (for example, it is desired to install version
5.8.4, even though version 5.8.4 is already installed). The software will reinstall over the
previously installed packages.

USE CASE: This checkbox needs be selected if it is ever desired to downgrade to a pre-
vious version of Software.

» Clean Upgrade — When checked, will return the NetClock 9400 to its original factory
configuration for the version of software being installed. (The Force Upgrade checkbox
will be automatically selected when the Clean Upgrade checkbox is selected.)

ﬂ Note: To perform a standard software upgrade, i.e. from an earlier software ver-

sion to the latest version, only the checkbox needs to be selected.
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Upgrade Status

In Progress

Analyzing...

Application 5186 - - In Progress
Timing FW 317 - - In Progress
Timing FPGA 37 - - In Progress
OC 11D 1F HW 01 010 - - In Progress
ocz2l 02 oooo - - In Progress
OC 31D FF HW oooo - - In Progress
OC 41D 01 HW D1 0103 - - In Progress
0C 51D 12 HW D 0105 - - In Progress
OC 6 1D 02 HW D1 0114 - - In Progress
Licensing - - - In Progress
GNSS oooo - - In Progress

OCS5PFW B127 - - In Progress

During the System Upgrade process, the Upgrade Log window on the right-side of the browser
will periodically have new entries asserted, indicating the update process is progressing.

Caution: Do not close the Web Ul, or attempt to reboot the unit. The installation is

in progress and may take several minutes to complete.

The Upgrade Status window will remain displayed during the upgrade progress, as long the
browser is not refreshed (such as by pressing the keyboard F5 key, for instance) or as long as
the web browser background is not clicked. If the page happens to be refreshed or the back-
ground clicked during the next few minutes while the update is being performed (causing the
Status window to disappear), this Status window cannot be re-opened. However, the software
update will continue to be performed with the window closed (the Upgrade Status window and
the Web Ul being open are not required for the update to be performed). The Status window
will periodically report status change updates.

ﬂ Note: If using a DHCP assigned IP address (instead of the unit having a statically

assigned IP address), the IP address may change once the update has completed
(it may be re-assigned a different IP address by the DHCP server).
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2.2.1

Automatic Reloading of the web page will not work if the address has been
changed by the DHCP server. Therefore, a new web browser connection using

the newly assigned IP address will need to be opened.

If the front panel LCD is configured to display network settings, the LCD window will show the
newly assigned IP address.

When using a static-assigned IP address (or if the DHCP server did not assign a new IP address
after the reboot), and as long the web browser didn't time-out during the update process (if it
times-out, press the F5 key to refresh the connection), once the update is complete, you will now
see the main page of the new web browser design.

Upgrade Log

The Upgrade Log is located in the upper-right corner of the Tools > Upgrade/Backup page of
the Web Ul. After completion of the upgrade process, the top of this log should indicate “Suc-
cessful”.

Upgrade Log

Potential Need to Repeat Upgrade Process
IMPORTANT: The upgrade process must be performed a second time, if:

a. your unit is equipped with a RES-SMT-GG receiver, and you are upgrading from a soft-
ware version 5.1.4 or lower

b. OR: If your unit is equipped with a u-blox M8T receiver, and you are upgrading from a
software version olderthan 5.5.0 .

This is required to update the receiver firmware.

Caution: Note the second time performing the same update process does require
the update file be uploaded into the time server again. The checkbox

must NOT be checked.
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2.2.1.1

22.1.2

2.2.2

30

With updateXxx.tar.gz ! in the update drop-down list after re-loading the update file,
just select Perform Upgrade again and click Submit. The second time through the update process
will be faster than the first time, as the receiver is the only item updated.

u-blox M8T: Upgrading to Version 5.8.4:

1. Update to software version 5.8.4.

2. The final update status page after reboot will show the u-blox M8T failed to update to
version 3.0.1 TIM 1.10.

3. Re-run the update again in order to update the u-blox M8T.

Should you see a version other than 3.0.1 TIM 1.10 displayed, the upgrade was not successful.
Proceed as follows:

a. Reset the receiver from the Web Ul: Navigate to Interfaces > References: GNSS Reference,
and click the GEAR button next to the GNSS Reference. In the GNSS O window, locate the
Reset Receiver box, check it, and click Submit.

b. If the version persists, reboot NetClock 9400.

c. Ifitstill persists, run the Release 5.8.4 update again.

RES-SMT-GG: Upgrading to Version 5.8.4:

1. Update to software version 5.8.4.

2. The final update status page after reboot will show the u-blox M8T failed to update to
version 1.9.

3. Re-run the update again in order to update the RES-SMT-GG.

Should you see a version other than 1.9 displayed, the upgrade was not successful. Proceed as
follows:

a. Reset the receiver from the Web Ul: Navigate to Inferfaces > References: GNSS Reference,
and click the GEAR button next to the GNSS Reference. In the GNSS O window, locate the
Reset Receiver box, check it, and click Submit.

b. If the version persists, reboot NetClock 9400.

c. Ifitstill persists, run the Release 5.8.4 update again.

Confirming Successful Installation

ﬂ Note: You will need to log into the Web Ul, using your login account information

1XYZ = New Software Version
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Navigate fo Tools > Upgrade/Backup. The new System software version should be displayed,
and the new GNSS Receiver version should be displayed (Trimble RES-SMT-GG: SW V1.9; u-
blox M8T: SW V3.0.1TIM 1.10.)

System Configuration

Sysiem Speciracom SecureSync

1200-233

Serial # 00000000
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3.1

3.2

@ spectracom

Upgrading via CLI

It is possible perform a software upgrade via a Command Line Interface, rather than using the
Web Ul, for example for scripting software updates.

Starting in Archive software version 4.8.8, the software update can be initiated using a CLI
command (issued via telnet, SSH or the front panel Serial port), instead of using the web
browser, if desired. This entails performing an FTP/SCP transfer of the software update file into
NetClock 9400’s /home/spectracom directory and then issuing the sysupgrade CLI com-
mand fo initiate the software upgrade.

Note: IMPORTANT: When transferring the update file using either FTP or SCP
(instead of uploading it using the web browser), make sure the Update file is
transferred using BINARY mode (SCP transfer is preferred, because it always
transfers using Binary mode). Otherwise, this file will likely be altered during the

file transfer, preventing the updater from being able to extract it. The following
error message will be asserted into the Update log if the Update file is
altered/can’t be extracted: “ERROR (-1) - Failure while unpacking Upgrade
Bundle (SWUE)".

The syntax for issuing the sysupgrade command is:

» Standard upgrade (Such as upgrading versions 4.8.8 to 4.8.9, for example): “sysup-
grade” followed by the upgrade file name (Example: sysupgrade update489.tar.gz).

» Forced upgrade (Such as downgrading versions 4.8.9 to 4.8.8, for example, but can
also be used with Standard upgrades, also): “sysupgrade force” followed by the
upgrade file name (Example: sysupgrade force update489.tar.gz).

» Clean upgrade (Such as first performing a Forced upgrade from 4.8.8 to 4.8.9, for
example. Then automatically resetting the NTP server back to factory default settings and
deleting all log files): “sysupgrade clean” followed by the upgrade file name (Example:
sysupgrade clean update489.tar.gz).

Saving/Restoring Configuration Files

Important note about restoring old configuration files

Due to fairly significant changes to the system configuration files from system software versions
prior to version 5.8.4, it is not recommended to perform a configuration restore with 5.8.4 soft-
ware installed, from a configuration save that was performed in a NetClock 9400 with versions
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3.3

3.4

4.8.9 or earlier installed. If a configuration restore from versions 4.8.9 or below software is
performed on a version 5.x.x time server, a ‘clean’ will be required to be performed via the
front panel keypad thereafter to reset the NTP server to the factory default settings for the
installed version.

In general, due to possible changes to configuration files from one version fo another, if you
wish to have a configuration backup file saved, we recommend performing a new “con-
figuration save” after each new software update is performed, to replace the earlier con-
figuration bundle. This will ensure that if a configuration restore is performed, the configs in
the captured file will be identical to the ones in the NTP server.

Software Update Log Entries

Software update log entries, such as upgrades that have already been performed, or an error
occurring during the update process, are placed in the Update Log (Tools > Logs page of the
Web Ul). Please refer to this log if you have any problems with the software update process
(such as if the message “Upgrade Failure” is displayed, for instance).

Downgrading the SW to a Previous Version

If desired, the software can be downloaded to previous versions 5.0.0 or higher (it is not
recommended to downgrade to versions 4.8.9 or below from versions 5.0.0 and above). The
downgrade process is the same as an upgrade, except an earlier version update bundle is
selected during the process and the update needs to be "Force Updated" (to override the ver-
sion checking that normally occurs).

Note: Due to incompatibilities between later and earlier configuration files, a
“Clean Upgrade” is also required to be performed during the software “down-

grade” process (the unit will need to be reconfigured as desired, once it's been
downgraded to the desired, earlier version).

NetClock 9400 Software Upgrade Instructions
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Note: You will not be able to apply a Saved configuration file from a later ver-
sion of software to any earlier, downgraded version of software to restore the

configurations. However, a saved config file previously performed when it was at
the earlier version can be safely re-applied as desired to restore configs.

Downgrading to an earlier version using the newer (black/charcoal background)

Web Ul:
To simultaneously downgrade and ‘Restore Factory Configuration”:
1. Navigate to the Tools > Upgrade/Backup page.
2. Press Update System software (on the left side of the screen, under Actions).

3. Verify the desired update bundle you wish to downgrade fo is in the File drop-down. If
not, press Upload New File and browse to where the earlier update bundle is stored.
Upload the bundle into the unit.

4. Select the Perfform Upgrade checkbox in the menu that opens, which will expand the
menu down to display two additional checkboxes.

5. Select the desired Update bundle version which you wish to downgrade fo.

6. Select also the Force Upgrade and Clean Upgrade checkboxes, before clicking Submit
(as shown in the screenshot below) to begin the downgrade. The Clean Upgrade check-
box resets all of the configurations back to factory default, as needed to occur when
downgrading to an earlier software version.

The software downgrade will take several minutes to complete.

ﬂ Note: If the software was downgraded back to a version prior to version

5.1.0, the “classic interface” will be displayed after logging back in, once
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ﬂ the downgrade has completed.

Upgrade System Software

File
4humefspeatrammfupnateﬁo
|:[L ‘home/spectracom/update502 tar.gz
= CITLE UpYIaus i

erform Upgrade

:{ Force Upgrade (Used to upgrade to current or lower version)

lean Upgrade (Check to load factory settings on upgrade)

Upload New File

1. Once downgraded, reconfigure the unit's settings as desired, or restore a previously
Saved config file from the version the software has been downgraded fo.

Downgrading to an earlier version using the “classic interface” Web Ul

To simultaneously downgrade and Restore Factory Configuration, in addition to selecting the
Update System, and Force Update checkboxes, also select the Restore Factory Configuration check-
box before clicking Submit (as shown in the screenshot below). The software downgrade will

take several minutes to complete.
The Restore Factory Configuration checkbox resets all of the unit's configurations back to the fact
ory default settings.

Note: If the software was downgraded back to a version prior to version 5.1.2,
the “classic" interface will be displayed after logging back in, once the down-

grade has completed.
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UPGRADE/BACKUP

[

Current Software Version

Solware Version Spectracem HetClock 3433 Varsion 5.0.0

Upload UpdateiLicense File

Upload File Browse_| |[_Upload ]
Upgrade the System Select the “Update System™, the “Force
Updow Ebe Upelobe 05 e 8 Update” and the “Restore Factory
Updete Syviem ¥ #———| Configuration” check-boxeswhen
o':‘:::m ¥ | downgrading to any previous version
= — (such as downgrading from version 5.0.2
Conbawnlse to version 4.8.9, for example).

Reconfigure the seftings as desired, or restore a previously saved config file from the version
the software has just been downgraded to.

“Upgrade Failure” (V. 5.0.2 to New Version|

If the Update process returns “Upgrade Failure” (as shown below), the software update process
was not successful.

UPGRADE STATUS

Upgrade Failure
Package Ok Version How Versica Acton Stans
Apphcanon SV - Anatyiing
Timing $W - B Anatyzing

If this happens, review the entries in the Update and System logs.

Applying the same version already installed or downgrading to an earlier version of software
without select the “Force Update” checkbox, in addition fo selecting the “Update System” check-
box can cause the upgrade fo fail. Make sure to select “Force update when applying the same
or earlier version of software.

The Update log may contain the following entry: “Error (-1) Failure while unpacking Upgrade
Bundle” / “Problem unpacking NWP bundle” (as shown below):

LOG FILES

Timestamps are in system timescale (UTC)

| Event || Alarms || Oscillator || GPS Gualification || NTP || Journal || Authentication || Update || Timing || System |

Nov 11 17:15:50 PSC-SecureSync FEC—Ser.ureSync [sw-upgrade] SW Upgrade Emor (8) (SWUE)

Now 11 17:15:48 PSC- ERROR (-1) - Failure while unpacking Upgrade Bundle {SWUE)
Nov 11 17:15:40 PSC- Pac ERROR {-1) - Problem unpacking NWP bundle (SWUE)

Mov 11 17:14:51 PSC- PSC Starling Update (SWUE)

Nov8 22:35:22 PSC-SecureSync FSCSecLlESylm [su-upgrade] SW Upgrade Error (3} (SWUE)

Mov8 22:35:21 PSC ERROR (-1} - Failure while unpacking Upgrade Bundle (SWUE)
Mow8 22:35:21 PSC Psc ERROR (-1} - Problem unpacking NWP bundie {SWUE})

Mow @ 22:34:25 PSC PSC Starting Update (SWUE})

Nov8 22:28:04 PSC-SecureSync PSC-SecureSync: [sw-upgrade] SW Upgrade Emor (8) (SWUE)
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Likely causes for this error message in the Update log

» The update file may be corrupt (preventing it from being able to be extracted in the time
server). Run MD5 checker against the update file to verify file integrity. Spectracom
provides the MD5 file for each software update file.

» Too many Update Bundles are stored in the time server. Delete previous update bundles
(such as update489, for instance).

Once a software update has been applied, the update bundle can be deleted (the bundles only
need fo be stored in the time server to alleviate the need to transfer them again to perform a
software downgrade. Otherwise, they can be safely deleted without affecting the time server).
Having too many upgrade files saved can prevent the update file being applied from being
able fo extract.

To delete earlier update files, select each one individually in the drop-down, check only the
“Delete Update File” checkbox in the screen where you normally select “Update File”. Then
press Submit. This will delete the selected update file. Then run the update process again.

UPGRADE/BACKUP

Current Software Version
Saftware Verslon Spoctracom NetClock 3483 Version 5.0.0

Upload Updata/Licensa File

Uploai Fika [Browse | |[_Upsond |

Upgrade the System

Upidate Fila wpdatedll e gz &
Update System = ‘
Forcu Updats 5 |

Dalsts Updats Fils C |
= o |

3.6 “Upgrade Failure” (V. >5.1.2 to New Version)

If the Update process returns “Upgrade Failure” (as shown below), the software update process
was not successful. Note that starting the update process again after it is already been started
will result in an “upgrade failure” of the subsequent update process, while the first one is still
being performed in the background.
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Upgrade Status

Application SW
Timing 8W

Timing FPGA

Licensing

If this happens, review the entries in the Update and System logs.

In Progress

Upgrade Failure

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

In Progress

@ spectracom

1. The time server may be refaining earlier upgrade bundle files which were applied and
are no longer needed. Previous update bundles should be deleted. For more inform-

ation, see "Deleting Old Update Files" on page 10.

2. Applying the same version already installed or downgrading to an earlier version of
software without select the “Force Update” checkbox, in addition to also selecting both
the “Force Upgrade” and “Clean Upgrade” checkboxes can cause the upgrade to fail.
Make sure to select the “Perform Upgrade”, “Force Upgrade” and “Clean Upgrade”
checkboxes when applying the same or earlier version of software.

3. The Update log may contain the following entry: “Error (-1) Failure while unpacking

Upgrade Bundle” / “Problem unpacking NWP bundle”

Likely causes for this error message in the Update log:

» The update file may be corrupt (preventing it from being able to be extracted in the time
server). Run MD5 checker against the update file to verify file integrity. Spectracom

provides the MD5 file for each software update file.

» Too many Update Bundles are stored in the time server. Delete previous update bundles
(such as update489, for instance).

viii
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Once a software update has been applied, the update bundle can be deleted (the bundles only
need fo be stored in the time server to alleviate the need to transfer them again to perform a
software downgrade. Otherwise, they can be safely deleted without affecting the time server).
Having too many upgrade files saved can prevent the update file being applied from being
able to extract.

To delete earlier update files, select each one individually in the drop-down, check only the
checkbox Delete Upgrade File in the screen where you normally select “Update File”. Then click
Submit. This will delete the selected update file. Then run the update process again.

Upgrade System Software

File

fhumEf’spectrawmfupdateﬁoa

Delete Upgrade File

Upload New File
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3.7.1

@ spectracom

Technical Support

To request technical support for your NetClock 9400 unit, please go to the "Support" page of
the Spectracom Corporate website, where you can not only submit a support request, but also
find additional technical documentation.

Phone support is available during regular office hours under the telephone numbers listed
below.

To speed up the diagnosis of your NetClock 9400, please send us:
» the current product configuration, and
» the events log (see "Saving and Downloading Logs" on page 1).

Thank you for your cooperation.

Regional Contact

Spectracom operates globally and has offices in several locations around the world. Our main
offices are listed below:

Table 3-1: Spectracom contact information

Country Location Phone Address

France Les Ulis +33 (0)1 64 53 39 80 Spectracom France
Parc Technopolis — Bat. Sigma

3, Avenue du Canada
91974 Les Ulis Cedex

USA Rochester, NY +1 585321 5800 Spectracom USA
1565 Jefferson Road, Suite 460
Rochester, NY 14623

Additional regional contact information can be found on the Contact page of the Spectracom
website.

NetClock 9400 Software Upgrade Instructions
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